use strict;
my $str = 'BBB 2324 WRETY RTJE, II 1111 (000) 000-0000 Date From: 01/01/2011, 01/11/2011 AAAAA / AAAA 111 AAAA AA AAAAAA, AA 11111-1111 (111) 111-1111 Date From: 01/11/2012 ';
my $regex = qr@([a-zA-Z0-9,()\s.#:/-]*?)Date From: [0-9]{2}/[0-9]{2}/[0-9]{4}([, \s]*[0-9]{2}/[0-9]{2}/[0-9]{4})*\s(Division Type: [A-Z ]*)*@mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}