re = /(?<=\```).+?(?=\```)/m
str = 'ilirsiniz:\\n\\n```java\\npu asd ilirsiniz
:\\n\\n```java\\npu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end