package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(bar).*(bar)`)
var str = `barbar`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}