using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\/?(embed|slider|---).*\]";
string input = @"[embed]
[---]
[sdfsfs]
[slider dsfsdf=fsdfs]
sdfsdfsf
[/slider]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}