re = /([^\^]*?)(\[.*\]|\{.*\}|)*(@\w+|)(=|[\+\-\*\/\%]=)(.*)/
str = 'aaa[bbb]@ccc=ddd
{aaa}@bbb+=ccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end