#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<span data-shortcode="iframe"[^>]*data-src=[\\\/]*\"(http:[\\\/]+([^\\\/]+)[^'\"]+)['\"]"
Local $sString = "<span data-shortcode="iframe" data-src="http://www.youtube.com/embed/ESFewdU0JcA" data-width="620" data-height="349" data-frameborder="0" data-allowfullscreen="1" data-scrolling="auto" data-alignment="none">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")