import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[幹乾淦贛干肏操糙去塞賽]?[林賃吝拎恁你他她它祂牠](娘|媽|老師|妹|祖?(嬤|媽|罵))(的|樂|叻|垃|勒|咧|([基唧雞機激][掰歪]))?|([基唧雞機激][掰歪])";
final String string = "幹\n"
+ "幹他媽的\n"
+ "幹你娘\n"
+ "乾\n"
+ "乾林老師\n"
+ "靠\n"
+ "靠北\n"
+ "靠杯\n"
+ "靠背\n"
+ "靠盃\n"
+ "靠腰\n"
+ "靠夭\n"
+ "哭夭\n\n"
+ "去你的\n"
+ "去你媽的\n\n"
+ "林北\n"
+ "恁北\n"
+ "恁娘\n"
+ "恁祖媽\n"
+ "機掰\n"
+ "賤\n"
+ "俗辣\n"
+ "他媽的\n"
+ "覽趴\n"
+ "懶趴\n"
+ "北爛\n"
+ "盧小\n"
+ "魯洨\n"
+ "色龜\n"
+ "肚爛\n"
+ "屌\n"
+ "啥小\n"
+ "三小\n"
+ "操\n"
+ "屁\n"
+ "唬爛\n"
+ "龜公\n"
+ "他奶奶的\n"
+ "犯賤\n"
+ "機車\n"
+ "智缺\n"
+ "你娘卡好\n"
+ "林老師\n"
+ "破麻\n"
+ "賽\n"
+ "操卒仔\n"
+ "操機歪\n"
+ "糙機掰\n"
+ "無懶趴\n"
+ "卡小\n"
+ "吃小\n"
+ "死魚眼\n"
+ "炭甲查某\n"
+ "糙你妹\n"
+ "GGININ\n"
+ "GG IN IN\n"
+ "GG IN IN DER\n"
+ "可惡 想揉\n"
+ "想揉\n"
+ "ㄈㄈ尺\n\n\n"
+ "英文原生:\n"
+ "CCR\n"
+ "Fuck off\n"
+ "Fuck\n"
+ "mother fucker\n"
+ "You SOB\n"
+ "son of a bitch\n"
+ "Go to hell\n"
+ "Shit-head\n"
+ "Asshole\n"
+ "You beast\n"
+ "Shit\n"
+ "fart\n"
+ "Idiot\n"
+ "damn it \n"
+ "God damn\n"
+ "God damn it\n"
+ "hypocrite\n"
+ "ass hole\n"
+ "ass licker\n"
+ "bitch \n"
+ "phycho\n"
+ "bastard\n"
+ "Whore\n"
+ "Slut\n"
+ "Shit-head\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}