$re = '/[^a-zA-Z\d\s]/m';
$str = 'lola-fern henderson
John Smith';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);