re = /(?<!\\)(?:\[{2}[^\n|]+(?:\|[^\n]+)?]]|\[[^\n]+]\([^\n:]+\))/
str = '[[Link name|title]]
[[Link name]]
[[do not
|match]]
[I am not a link]]
some (text) [[Link]] more [text]
\\[[This is not a link]]\\[[[this is|a link]] foo bar ]
[[Folder Name/Link|link]]
[[Folder/other folder/file|label]]
[[]]
[[A [link] with brackets]]
[[A [link] with brackets|on [both] sides]]
[[A [bracket] folder/A [link] with brackets|on [both] sides]]
Markdown: [Three laws of motion](Three%20laws%20of%20motion.md)
\\[Not a link](Three%20laws%20of%20motion.md)
[also
not](a link)
[This [is] a link](Three%20laws%20of%20motion.md)
[Yes, you can put (parens) and [brackets] in a filename](Yes,%20you%20can%20put%20(parens)%20and%20[brackets]%20in%20a%20filename)
[This is an external link](https://regex101.com)
[[#Preview a linked file]] is a link to a heading in the current document.
[[Obsidian#Links are first-class citizens]] is a link to a heading in another document.
[[Help and support#Questions and advice#Report bugs and request features]] is a link to a subheading in another document.
You can link to a block by adding #^ at the end of your link destination followed by a unique block identifier. For example, [[2023-01-01#^37066d]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end