$re = '/^\d+\.*\d*$/m';
$str = '1234.4234.234
12.234
1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);