import Foundation
let pattern = #"^https?:\/\/(?:[^@\/\n]+@)?(?:www\.)?([^:\/\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
random
123
www.co
http://calgarymayor.ca/
http://calgarymayor.ca/Disclosure%20docs/Expenses/Budget%20ending%202017-04-30.pdf
http://calgarymayor.ca/bio
http://citytalk.calgary.ca/
http://citytalk.calgary.ca/careers
http://www.calgaryarb.ca
http://www.calgaryarb.ca/eCourtPublic/15M2018.pdf
http://www.calgarymlc.ca/
http://www.calgarymlc.ca/about-cmlc/
http://www.calgarypolicecommission.ca/ *********
http://www.calgarypolicecommission.ca/reports.php *******
http://www.citiesmatter.ca/
https://attainyourhome.com/ ********
https://cityonline.calgary.ca/Pages/Cart.aspx ******
https://data.calgary.ca/
https://data.calgary.ca//api/views/24tg-us6q/rows.rss?accessType=DOWNLOAD
https://data.calgary.ca/Base-Maps/Alberta-Township-Sections/q6ds-xz2v/data
https://engage.calgary.ca/
https://liveandplay.calgary.ca/DROPIN/page/dropin *******
https://maps.calgary.ca
https://myid.calgary.ca/idm/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)