re = /\btext \(jadad\)(?!\w)/mi
str = 'lipsum is a dummy text (jadad) alsdasldk. // match
lipsum is a dummy text (jadad). // match
lipsum is a dummy text (jadad) // match
lipsum is a dummy (text (jadad)) // match
lipsum is a dummy text (jadad // should not match
lipsum is a dummy text jadad) // should not match
lipsum is a dummy text (jadad)asd // should not match
lipsum is a dummy ()text (jadad)asdasd // should not match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end