import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\"access_token\\\" : ).*";
final String string = "{\n"
+ " \"access_token\": \"eyJraWQiOiJhZTYxYWIxZi0yNTRhLTQ5ZWQtODMzNC05ZDJlN2E0MzZiNGQuaG9tLmdlbi4xNTk3NjAwMzM2OTkyLmp3dCIsImFsZyI6IlJTMjU2In0.eyJzdWIiOiIxMjY2YWFlOC04NGU5LTRiZjQtYWU2Mi1hOTRiZGMyY2M3NmIiLCJpc3MiOiJodHRwczovL29wZW5pZC5pdGF1LmNvbS5ici9hcGkvb2F1dGgvdG9rZW4iLCJpYXQiOjE2NTIzODExNDcsImV4cCI6MTY1MjM4MTQ0NywiQWNjZXNzX1Rva2VuIjoiMmFhM2ZlOTUuNzJkM2RkZDEtMjY0NC00NWU2LWI1YjEtMTg0N2FjNTZmMWRhIiwidXNyIjoibnVsbCIsImZsb3ciOiJDQyIsInNvdXJjZSI6IklOVCIsInNpdGUiOiJkZXYiLCJlbnYiOiJIIiwibWJpIjoidHJ1ZSIsImF1dCI6IiIsInZlciI6InYxLjAiLCJzY29wZSI6Im1mLkNJQ1MgcmVzb3VyY2UuUkVBRCBtZi5RVCBtZi5JTVMgbWYuR1JCRSBhcHBpZC1iMWY1ZGIzMS02MzMxLTQwOTgtYTg4MS03MDRhOTEwMDhhYzQifQ.C29wuhkVvrR9KJ-g_BqziDUXcYIHL3vEsvNcHdJ9qCWceV8vWTbj9flt75SdkEmUkeOpxwKzZ9bt5ML680qtqhM5nOlQp7VMnJ3YM-f8myJI5db8ydkZ_2i0uy50I4VSy9091qjkoykD1LA9G_9SdCpKxunFRONxaZMeWbTs3phL9pHCuxai63PlHPGg8zYvYhOheK131epoAxyRS6-qCIY9OgqQWKg5fQxNu3xOKdTfyCvULPobSfVFNuwrUQWiVClju_qcoNTAyXl0T-sNuKKfqdVdm9AehMtXjNBGeG3a77AutLu2E-0PkQGxs9pM7D3pcbWhSiZJOZnAaV5bYw\",\n"
+ " \"refresh_token\": \"eyJraWQiOiJyZWZyZXNoLmhvbS5nZW4uaW50ZXJuYWwuand0IiwiYWxnIjoiUlMyNTYifQ.eyJzdWIiOiIxMjY2YWFlOC04NGU5LTRiZjQtYWU2Mi1hOTRiZGMyY2M3NmIiLCJpc3MiOiJodHRwczovL29wZW5pZC5pdGF1LmNvbS5ici9hcGkvb2F1dGgvdG9rZW4iLCJpYXQiOjE2NTIzODExNDcsImV4cCI6MTY1MjQyNDM0NywiQWNjZXNzX1Rva2VuIjoiZTcxNTgzYTFkLmEwMDY3NGMzLWFhNDEtNGY5MC1hN2QxLTkxMjBkYmYwNjQ5YyIsInVzciI6Im51bGwiLCJmbG93IjoiQ0MiLCJzb3VyY2UiOiJJTlQiLCJzaXRlIjoiZGV2IiwiZW52IjoiSCIsIm1iaSI6InRydWUiLCJhdXQiOiIiLCJ2ZXIiOiJ2MS4wIiwic2NvcGUiOiJtZi5DSUNTIHJlc291cmNlLlJFQUQgbWYuUVQgbWYuSU1TIG1mLkdSQkUgYXBwaWQtYjFmNWRiMzEtNjMzMS00MDk4LWE4ODEtNzA0YTkxMDA4YWM0In0.TiUf9yUj5Gnxf-p8iMVHoRVh3ssM6DBOvxsYdz-mMo3kM7cmiKoFz9LtholHrohC6BRxkQdSfWl-RXz4TyWuWTAsKEKTjfSw0NimhQ5fUq2D_OHFgFyVjxxuMOaU4aVBcyTT3bvhixkIB72_BYoSb0ACFmWhHDreg_B0hpTIzTJs4FPUGL2nMUFzdXMuXu080jXjeVvd2l5rMRJwNow91kclCTc2vRtziK5PuJJfiTI7QfLc_LiyesZpeH8pm7sMCpQY-G-xKzlZgrankneO2wnUbAd-hBq7MxERw_hR-49ZS_qzMKCtlEiT1hZqkCFpErf4ucCDIZ3c7jXijT_R-A\",\n"
+ " \"scope\": \"mf.CICS resource.READ mf.QT mf.IMS mf.GRBE appid-b1f5db31-6331-4098-a881-704a91008ac4\",\n"
+ " \"active\": true,\n"
+ " \"token_type\": \"Bearer\",\n"
+ " \"expires_in\": 300\n"
+ "}";
final String subst = "eyJhbGciOiJIUzI1NiJ9..73wb-VXApdLp1P2SEXCk7EWALdc3K0paOfjdbr4yZ4s";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}