$re = '/(?s)(?<=>).*?(?=\n{2,})/';
$str = '> line 4
> line 5
> line 1
line 2
line 3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);