$re = '/\d+(?=:)/';
$str = '16,1-5,22-27&22:1&4:3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);