$re = '/[^:;]+/';
$str = '4313 :F:7222;scott miles:F:7639;Henry Gile:G:3721';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);