package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^0\d(?:[ .-]?\d{2}){4}$`)
var str = `0145391617`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}