$re = '/(<\?php.*?)\$lang\[([^]]*)]/';
$str = '<?php echo $lang[\'extension_not_allowed\'] ?>';
$subst = "$1$this->$lang($2)";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;