$re = '/\b(\d+)(\d{2})\b/';
$str = '300000';
$subst = "$1.$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;