const regex = new RegExp('(?<=__)(\\d+)(?=\\.bag)', '')
const str = `allData__2017-04-18-11-30-20_0.bag`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}