$re = '/£[5-9]\d{2,}|£[1-9]\d{3,}/m';
$str = 'Line 60166: £5.99
Line 60294: £59.99
Line 60493: £5.53
Line 60619: £5.19
Line 60829: £5.88
Line 60847: £5.18
Line 61508: £5.98
Line 61771: £5.27
Line 61777: £5.99
Line 61789: £5.49
Line 61893: £5.00
Line 61899: £56.49
Line 61940: £500.91
Line 23832: £9484.94
Line 23832: £944.94
Line 23832: £94.94
Line 23832: £584.94
Line 23832: £1000.94';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);