use strict;
my $str = 'ECSE-4530 Digital Signal Processing
Rich Radke, Rensselaer Polytechnic Institute
Lecture 5: the Fourier Transform (9/11/14)
shsdhsh<a class="yt-simple href="/watch?v=5HSn3DPHQcQ&t=2s">0:00:02</a> The Fourier Transform.
Shshshsh<a class="yt-simple" href="/watch?v=5HSn3DPHQcQ&t=219s">0:03:39</a> Thinking ofles of a function
shgshshshs<a class="yt-simple" href="/watch?v=5HSn3DPHQcQ&t=463s">0:07:43</a> Derivim aiod goes to infinity';
my $regex = qr/(?<txt_pre_linka>\w+)?(?<ceo_link><a .*?>.*?<\/a>)(?<txt_after_linka>.*?)(?=<a .*?>.*?<\/a>|$|\.)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}