# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!--StartFragment-->([\s\S]*?)<!--EndFragment-->/$1/gm;t' <<< "<html>
<body>
<!--StartFragment--><span style=\"box-sizing: border-box; color: rgb(17, 17, 17); font-size: 14px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: 0.25px; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: pre-wrap; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: rgb(255, 255, 255); text-decoration-style: initial; text-decoration-color: initial; font-family: "Segoe UI", sans-serif;\">We have checked the sample </span><!--EndFragment-->
</body>
</html>"