re = /^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$/i
str = 'thomas-o\'leary@upenn.org'
# Print the match result
str.match(re) do |match|
puts match.to_s
end