import Foundation
let pattern = ##"""
(?<!\\) # negative look-behind to make sure start is not escaped
(?: # start non-capture group for all possible match starts
# group 1, match dollar signs only
# single or double dollar sign enforced by look-arounds
((?<!\$)\${1,2}(?!\$))|
# group 2, match escaped parenthesis
(\\\()|
# group 3, match escaped bracket
(\\\[)|
# group 4, match begin equation
(\\begin\{equation\})
)
# if group 1 was start
(?(1)
# non greedy match everything in between
# group 1 matches do not support recursion
(.*?)(?<!\\)
# match ending double or single dollar signs
(?<!\$)\1(?!\$)|
# else
(?:
# greedily and recursively match everything in between
# groups 2, 3 and 4 support recursion
(.*(?R)?.*)(?<!\\)
(?:
# if group 2 was start, escaped parenthesis is end
(?(2)\\\)|
# if group 3 was start, escaped bracket is end
(?(3)\\\]|
# else group 4 was start, match end equation
\\end\{equation\}
)
))))
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
NOTE: For test purposes each test has been contained to one line, please enable the s flag for multi-line matches.
$ match $ don't match nested $ match $
$$ no match$
$no match$$
\\$no match\\$
$no match\\$
\\$no match\\$
$$ match $$ don't match nested $$ match $$
$$$ no match $$
$$ no match $$$
\\$$ no match$$
$$ no match\\$$
\\$$ no match\\$$
\( match \)
\( 1 \( nested match \) 3 \)
\\( no match \\)
\( no match \\\\)
\\\\( no match \\\\)
\[ match \]
\[ 1 \[ nested match \] 3 \]
\\\\[ no match \\]
\\[ no match \\\\]
\\\\[ no match \\\\]
\begin{equation} match \end{equation}
\begin{equation} 1 \begin{equation} nested match \end{equation} \end{equation}
\\\\begin{equation} no match \\end{equation}
\\begin{equation} no match \\\\end{equation}
\\\\begin{equation} no match \\end{equation}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)