$re = '/^[a-z]+$/im';
$str = 'qsdfmliojjmois
qsdflk
45qsdf
qsd78qs
d-sd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);