$re = '/\B\[([\w-]+)=([\w-]+)(?:,[\w-]+=[\w-]+)*\]/m';
$str = '[tag=blue]Hello [tag2=red,tag3=blue]Good';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;