using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/?[\w-/]+$";
string input = @"/home/user/Documents
/home/user/Documents-list_-/
home/user/Documents-list_-/
home/
space /home/user/Documents/file.name
/home/user/Documents/foo.log
/foo.bar
/folder
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}