$re = '/(?!\b(?:are|finite|get|er)\b)\S*(?:are|finite|get|er)\S*/m';
$str = 'You are definitely getting better today, er finite or get?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);