const regex = /(?!\b[A-Z]((\w*))\b)\sSouls+(?!\s[A-Z,0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\b[A-Z]((\\w*))\\b)\\sSouls+(?!\\s[A-Z,0-9])', 'gm')
const str = `When I finally finished Dark Souls for the first time, that feeling of struggle and triumph, of having wandered a vast and lonesome landscape, stuck with me for weeks.
The creator of the Souls series and game director on Sekiro: Shadows Die Twice.
The Souls Game start with competent price.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}