re = /(?:2|two)\sweeks\s\K
(?|(Mon|Tue(s)?|Wed(nes|s)?|Thu(rs|r)?|Fri|Sat(ur)?|Sun))(day|d)?
/x
str = 'blah 2 weeks Wed blah'
# Print the match result
str.match(re) do |match|
puts match.to_s
end