package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(\d+)[^\d]*$`)
var str = `http://www.hello.com/index.php?page=11asddasds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}