$re = '/(?i)(beautiful)?(?:(?!beautiful|people[a-zA-Z0-9]).)*(people[a-zA-Z0-9]{2,3})/';
$str = 'I am beautiful, charming and friendly people00"
"I am beautiful, charming and friendly peopleXXX"
"I am charming and friendly people00"
"I am charming and friendly peopleXXX"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);