$re = '/^(?!google\.com\.sg)(?<url>[^\n]+)(?:\n|)/m';
$str = 'google.com
google.com.sg
facebook.com
splunk.com
answers.splunk.com
idontknowanyurlsanymore.ru
iamahorseandilikeit.horse.me
factor.io';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);