#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<div[^>]+class=\"fb-(video|post)\".*data-href=\"(.*)\"[^>]*>[\s|\S]*?<\/div>\n*<\/div>"
Local $sString = "fbEmbeddedContent:" & @CRLF & _
"<p>(7 ม.ค.) ในโลกออนไลน์ได้มีการแชร์คลิปวีดีโอจากเฟซบุ๊กของคุณฮันนี่ควีน พันธุ์ชิต ซึ่งได้โพสต์คลิปพร้อมข้อความว่า "คลิปนี้เป็นคลิปที่น้องชายโดนมอเตอร์ไซค์เหยียบอก เอกซเรย์ซี่โครงหัก 4 ท่อน ขอความเป็นธรรมด้วยค่ะ" โดยเหตุเกิดที่ อ.เสนา จ.พระนครศรีอยุธยา</p>" & @CRLF & _
"<p>จากคลิปเผยให้เห็นภาพจากกล้องวงจรปิดจากร้านแห่งหนึ่ง ซึ่งฝั่งตรงข้ามได้มีรถยนต์เข้ามาจอดที่ริมฟุตปาธอีกฝั่งหนึ่ง ก่อนที่คนขับจะเปิดประตูรถลงมา และชนกับรถจยย.ซึ่งพาเด็ก 2 คนนั่งซ้อนท้าย จนรถจยย.ล้ม </p>" & @CRLF & _
"<p>ขณะเดียวกันก็มีรถจยย.อีกคันขับสวนเลนมา และเหยียบไปที่ร่างของเด็ก ด้วยความตกใจหญิงสาวซึ่งเป็นคนขี่รถจยย.ได้ลุกขึ้นมาอุ้มเด็กคนดังกล่าว ก่อนที่ชาวบ้านจะเข้ามามุงดูเหตุการณ์ที่เกิดขึ้น</p>" & @CRLF & _
"<p>ทั้งนี้ ผู้โพสต์คลิปดังกล่าวระบุว่า เตรียมจะเอาเรื่องคนขับรถยนต์คันดังกล่าวถึงที่สุด เพราะเป็นต้นเหตุที่ทำให้น้องของเธอถูกรถจยย.เหยียบร่าง จนซี่โครงหักถึง 4 ท่อน </p>" & @CRLF & _
"<p><em>ขอขอบคุณคลิปจากเฟซบุ๊กของคุณ<a href="https://www.facebook.com/100009910685001/videos/209456276061394/" target="_blank">ฮันนี่ควีน พันธุ์ชิต</a></em></p>" & @CRLF & _
"<script type="text/javascript">// <![CDATA[" & @CRLF & _
"(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/th_TH/sdk.js#xfbml=1&version=v2.3"; fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));" & @CRLF & _
"// ]]></script>" & @CRLF & _
"<div class="fb-video" data-allowfullscreen="1" data-href="/100009910685001/videos/vb.100009910685001/209456276061394/?type=3">" & @CRLF & _
"<div class="fb-xfbml-parse-ignore">" & @CRLF & _
"<blockquote cite="https://www.facebook.com/100009910685001/videos/209456276061394/"><a href="https://www.facebook.com/100009910685001/videos/209456276061394/"></a>" & @CRLF & _
"<p>คลิปนี้เป็นคลิปที่น้องชายโดนมอไซค์เหยียบหน้าอก..เอ็กซ์เรย์ซี่โครงหัก4ท่อนขอความเป็นธรรมด้วยนะค่ะ</p>" & @CRLF & _
"Posted by <a href="https://www.facebook.com/people/ฮันนี่ควีน-พันธุ์ชิต/100009910685001">ฮันนี่ควีน พันธุ์ชิต</a> on 6 มกราคม 2016</blockquote>" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"<p>จากกรณีดารานักแสดงตบเท้าเข้าชี้แจงกับ <strong>นพ.สมาน ฟูตระกูล</strong> ผู้อำนวยการสำนักงานคณะกรรมการควบคุมเครื่องดื่มแอลกอฮอล์ กรมควบคุมโรค กระทรวงสาธารณสุข จากกรณีโพสต์ภาพเครื่องดื่มแอลกอฮอล์ลงในโซเชียลมีเดีย</p>" & @CRLF & _
"<div class="fb-video" data-allowfullscreen="1" data-href="/aloha.tack/videos/vb.1528555579/10208309416202889/?type=3">" & @CRLF & _
"<div class="fb-xfbml-parse-ignore">" & @CRLF & _
"<blockquote cite="https://www.facebook.com/aloha.tack/videos/10208309416202889/"><a href="https://www.facebook.com/aloha.tack/videos/10208309416202889/"></a>" & @CRLF & _
"<p>ตามนั้น</p>" & @CRLF & _
"Posted by <a href="https://www.facebook.com/aloha.tack">แทค ภรัณยู โรจนวุฒิธรรม</a> on 3 พฤศจิกายน 2015</blockquote>" & @CRLF & _
"</div></div>" & @CRLF & _
"<p>#ถึงเป็นควาย #ก็เซฟชีวิตผู้โดยสารทุกคนจากความชิบหายมานักต่อนักแล้วนะคะ"</p> <p><em>ขอขอบคุณข้อมูลจาก <a href="https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3">เฟซบุ๊ก Crewabs Cabincrew</a></em></p> <script type="text/javascript">// <![CDATA[ (function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/th_TH/sdk.js#xfbml=1&version=v2.3"; fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk')); // ]]></script> <div class="fb-post" data-href="https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3" data-width="500"> <div class="fb-xfbml-parse-ignore"> <blockquote cite="https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3"> <p>จากใจแอร์สาวบนไฟล์ทที่โดนหนุ่มรถไฟจีบด้วยมุก"ระเบิด"กรณีหนุ่มรถไฟ แซวแอร์ไทยไลอ้อน อยากขอพื้นที่ชี้แจงให้ลูกเรือสาวในไ...</p> Posted by <a href="https://www.facebook.com/CrewabsCabincrew/">Crewabs Cabincrew</a> on <a href="https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3">3 พฤศจิกายน 2015</a></blockquote> </div>" & @CRLF & _
"</div>test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")