$re = '/string(.*?)string/m';
$str = 'stringfindenstring
string_strang_string
string-strong-string
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);