# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=## )(.*?)(?= #)"
test_str = ("### Example New Feature ###\n\n"
"This is a short description of the new feature. Group two or more closely related features using a common section with h4 subsections. Link to associated documentation as shown below (based on the number of links).\n\n"
"See also: [Associated Documentation](Associated_Documentation.md)\n\n"
"See also: [Associated Documentation](Associated_Documentation.md) and [Associated Documentation](Associated_Documentation.md)\n\n"
"See also: [Associated Documentation](Associated_Documentation.md), [Associated Documentation](Associated_Documentation.md), and [Associated Documentation](Associated_Documentation.md)\n"
"{% endcomment %}\n\n\n"
"## User Interfaces ##\n\n"
"This section describes new features for user interfaces, including Tempo, sites, and embedded interfaces.\n\n"
"### Sites Revolution ###\n\n"
"#### Tempo Reports in Sites ###\n\n"
"In addition to task reports, actions and record types, designers can now configure sites to have Tempo reports. Making it easier for sites only users to view and analyze data.\n\n"
"<img class=\"screenshot\" src=\"images/release_notes/SitesTempoReports.png\"/>\n\n"
"[configure sites with reports](Sites.md#Configure_a_Site_Page).\n\n"
"#### Inline Task Management ###\n\n"
"Task management has improved for users of all Appian user environments. All task management controls for SAIL [tasks](Tasks.md), including save changes, reassign, and reject, have been moved to above the task form.\n\n"
"The left-hand navigation bar no longer appears in Tempo when viewing SAIL tasks, allowing task forms to occupy the full page width.\n\n"
"These task management controls are now available to [sites](Sites.md) users for the first time.\n\n"
"Users of [embedded](Embedded_Interfaces.md) tasks now have the option to save changes to SAIL tasks.\n\n"
"<img src=\"images/release_notes/InlineTaskControls.png\" class=\"screenshot\"/>\n\n\n"
"#### User Record in Sites ###\n\n"
"We have made it possible for designers to configure the User record and User record links in sites.\n\n"
"<img class=\"screenshot\" src=\"images/release_notes/SitesUserRecord.png\"/>\n\n"
"#### User Profile in Sites ###\n\n"
"Users can now update their profiles in a site by clicking on their avatar in the header and clicking on the Profile button. \n\n"
"<img class=\"screenshot\" src=\"images/release_notes/SitesUserProfile.png\"/>\n\n"
"#### Wider Sites ###\n\n"
"Following in Tempo's footsteps, sites are now 25% wider, allowing more room for items like charts and graphs. \n\n"
"<img src=\"images/release_notes_16_3/Wider_Sites.png\" />\n\n\n"
"### Quick Apps Revolution ###\n\n"
"#### Sites Are Now Available for Quick Apps ###\n\n"
"You can now generate a [site](Sites.md) for any [Quick App](Quick_Apps_Designer.md). This allows focused users or users new to Appian to experience the app in a standalone setting.\n\n"
"<img src=\"images/Quick_Apps/quickAppsSite.png\" class=\"screenshot\"/>\n\n"
"Simply check the box when creating or updating a Quick App, or when creating an application through the [application builder](Applications.md#Create_Using_Application_Builder), and a site will be generated with pages for the record list, action, and report. The site also contains a new task report that allows users to see all their tasks and send new ones from any record.\n\n"
"#### New Quick Apps Task Report ###\n\n"
"Each Quick Apps now comes with a task report in addition to the functionality provided in 16.2. This report appears in the Tasks tab in Tempo (and in your site, if you have one for that Quick App) and shows all of the current user's tasks in that Quick App, as well as allowing them to send new tasks directly from the report!\n\n"
"To get this in any of your existing Quick Apps, simply run any update of the app through the Quick Apps Designer, and the task report will be automatically added to your app.\n\n"
"<img src=\"images/Quick_Apps/quickAppsTaskReport.png\" class=\"screenshot\"/>\n\n\n"
"### Wider Tasks in Tempo\n\n"
"The left-hand navigation bar no longer appears in Tempo when viewing SAIL tasks, allowing task forms to occupy the full page width.\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.