$re = '/[0-31][0-24][0-60].Z/';
$str = '101010Z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);