$re = '/(\d)\1{9}/';
$str = '1111111111
2222222222
1312312312';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);