$re = '/(?<=c)[0-9]*(?=}|$)/m';
$str = 'categories<{catalog01_c2975_c3984}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);