package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*[A-Z].*[A-Z]([^\n]+)`)
var str = `AAAAAAAAAAAAAAAAAAAAAA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}