package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(@[\w\s]*)[^@\r\n\W]`)
var str = `@avner raphael`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}