$re = '/^[\w-]+@[\da-zA-Z]+\.[a-zA-Z]{1,3}$/';
$str = 'a@b.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);