package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)STR\("((?:\\"|[^"])*)"\)`)
var str = `STR("<some_string>")
STR("test \") string")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}