$re = '/(<=^| )(\*[ABC])\b/';
$str = 'AA *X IJ XYZ 7F *A OF *B 3C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);