package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\w+\((.+)\)`)
var str = `a = func(a, b, cde);
hello(123);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}