package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((| |[^.])+(?:[\uD800-\uDBFF]|<:\w+:\d+>|)(| |[^.])+){1,27}$`)
var str = `🤔`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}