const regex = /<p>(\s*)(<a(.*)>)?(\s*)(https?:\/\/)?(w{3}\.)?(youtube\.com|youtu\.be)\/(watch\?v=|embed\/)?([A-Za-z0-9-_]{11})(\S*)(\s*)(<\/a>)?(\s*)<\/p>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>(\\s*)(<a(.*)>)?(\\s*)(https?:\\\/\\\/)?(w{3}\\.)?(youtube\\.com|youtu\\.be)\\\/(watch\\?v=|embed\\\/)?([A-Za-z0-9-_]{11})(\\S*)(\\s*)(<\\\/a>)?(\\s*)<\\\/p>', 'g')
const str = `No protocol:
<p>youtube.com/watch?v=dQw4w9WgXcQ</p>
<p>www.youtube.com/watch?v=dQw4w9WgXcQ</p>
HTTP or HTTPS:
<p>http://youtube.com/watch?v=dQw4w9WgXcQ</p>
<p>http://www.youtube.com/watch?v=dQw4w9WgXcQ</p>
<p>https://youtube.com/watch?v=dQw4w9WgXcQ</p>
<p>https://www.youtube.com/watch?v=dQw4w9WgXcQ</p>
With or without “www”
<p>https://youtube.com/watch?v=dQw4w9WgXcQ</p>
<p>https://www.youtube.com/watch?v=dQw4w9WgXcQ</p>
Youtu.be short links
<p>youtu.be/LQaehcfXvK0</p>
<p>https://youtu.be/LQaehcfXvK0</p>
Embed Urls:
<p>http://www.youtube.com/embed/dQw4w9WgXcQ</p>
URLs with extra parameters:
<p>https://www.youtube.com/watch?v=LQaehcfXvK0&feature=youtu.be</p>
<p>https://www.youtube.com/watch?v=dQw4w9WgXcQ&list=RDdQw4w9WgXcQ&start_radio=1&t=1</p>
This URL won’t actually work on YouTube, but it works here, which is somewhat odd? And yet doesn't seem harmful.
<p>youtu.be/embed/dQw4w9WgXcQ</p>
Paragraph tags on separate lines with arbitrary whitespace:
<p>
www.youtube.com/embed/u8pCsfT1gDU
</p>
<p>
https://youtube.com/watch?v=dQw4w9WgXcQ
</p>
<p>
http://www.youtube.com/embed/dQw4w9WgXcQ
</p>
<p>
youtube.com/watch?v=dQw4w9WgXcQ
</p>
Paragraph tags with any other text in them, besides the URL:
<p>This shouldn’t work: https://youtube.com/watch?v=dQw4w9WgXcQ</p>
<p>https://youtube.com/watch?v=dQw4w9WgXcQ nor this</p>
<p>
https://youtube.com/watch?v=dQw4w9WgXcQ also not this
</p>
Paragraph tags with links added by markdown-it:
<p><a href="https://www.youtube.com/watch?v=dQw4w9WgXcQ">https://www.youtube.com/watch?v=dQw4w9WgXcQ</a></p>
<p>
<a href="https://www.youtube.com/watch?v=dQw4w9WgXcQ?something" class="something" id="whatever">
youtube.com/watch?v=dQw4w9WgXcQ?foo=bar&whatever
</a>
</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}