$re = '/^((?!Fig\.\s*\\\\ref\{fig).)*$/m';
$str = 'Fig. \\ref{fig:myFigure}
A sentence with Fig. \\ref{fig:myFigure} there.
\\ref{fig:myFigure}
A sentence with \\ref{fig:myFigure} there.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);