import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "INSERT INTO[\\s]*(.*?)[\\s]*\\((.*?)\\)\\s*VALUES\\s*\\((.*?)\\)[\\s|;]*";
final String string = "INSERT INTO TABLE ([fis_RECno], [fis_RECid_DBCno], [fis_RECid_RECno], [fis_SpecRECno], [fis_iptal], [fis_fileid], [fis_hidden], [fis_kilitli], [fis_degisti], [fis_checksum], [fis_create_user], [fis_create_date], [fis_lastup_user], [fis_lastup_date], [fis_special1], [fis_special2], [fis_special3], [fis_firmano], [fis_subeno], [fis_maliyil], [fis_tarih], [fis_sira_no], [fis_tur], [fis_hesap_kod], [fis_satir_no], [fis_aciklama1], [fis_meblag0], [fis_meblag1], [fis_meblag2], [fis_meblag3], [fis_meblag4], [fis_meblag5], [fis_meblag6], [fis_sorumluluk_kodu], [fis_ticari_tip], [fis_ticari_DBCno], [fis_ticari_RECno], [fis_kurfarkifl], [fis_ticari_evraktip], [fis_tic_evrak_seri], [fis_tic_evrak_sira], [fis_tic_belgeno], [fis_tic_belgetarihi], [fis_yevmiye_no], [fis_katagori], [fis_evrak_DBCno], [fis_fmahsup_tipi], [fis_fozelmahkod], [fis_grupkodu], [fis_aktif_pasif], [fis_proje_kodu]) \n"
+ "VALUES ('65918', '0', '65918', '0', '0', '2', '0', '0', '0', '0', '37', '2016-03-01 17:19:16.413', '37', '2016-03-01 17:19:16.413', N'', N'', N'', '0', '0', '2016', '2016-01-06 00:00:00.000', '180', '0', N'689.00.003', '5', N'yuvarlama', '-0.04', '-0.013707549433', '-0.04', '0', '0', '0', '0', N'', '0', '0', '0', '0', '0', N'', '0', N'', '1899-12-30 00:00:00.000', '2086', '0', '0', '0', N'', N'', '0', N'');\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}